PHP 5.3.x < 5.3.15 Multiple Vulnerabilities

high Log Correlation Engine Plugin ID 801075
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server uses a version of PHP that is affected by an multiple vulnerabilities.

Description

PHP versions 5.3.x earlier than 5.3.15 are affected by the following vulnerabilities.

- - An unspecified overflow vulnerability exists in the function '_php_stream_scandir' in the file 'main/streams/streams.c'. (CVE-2012-2688)

- An unspecified error exists that can allow the 'open_basedir' constraint to be bypassed. (CVE-2012-3365)

Solution

Upgrade to PHP version 5.3.15 or later.

See Also

http://www.php.net/ChangeLog-5.php#5.3.15

Plugin Details

Severity: High

ID: 801075

Family: Web Servers

Published: 8/28/2012

Updated: 8/28/2012

Nessus ID: 60085

Risk Information

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 7/19/2012

Vulnerability Publication Date: 7/19/2012

Reference Information

CVE: CVE-2012-2688, CVE-2012-3365

BID: 54638, 54612