PHP 5.3.x < 5.4.3 Multiple Vulnerabilities

high Log Correlation Engine Plugin ID 801071
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server uses a version of PHP that is affected by a code execution vulnerability.


Description

PHP versions earlier than 5.4.3 are affected by the following vulnerabilities.

- The fix for CVE-2012-1823 does not completely correct the CGI query parameter vulnerability. Disclosure of PHP source code and code execution via query paramenters are still possible. Note that his vulnerability is exploitable only when PHP is used by CGI-based configurations. Apache with 'mod-php' is not an exploitable configuration. (CVE-2012-2311, CVE-2012-2335, CVE-2012-2336)

- An unspecified buffer overflow exists related to the function 'apache_request_headers'. (CVE-2012-2329)

Solution

Upgrade to PHP version 5.4.3 or later.

See Also

https://bugs.php.net/bug.php?id=61910

eindbazen.net/2012/05/php-cgi-advisory-cve-2012-1823

http://.php.net/archive/2012.php#id2012-05-08-1

http://.php.net/ChangeLog-5.php#5.4.3

Plugin Details

Severity: High

ID: 801071

Family: Web Servers

Published: 6/5/2012

Updated: 6/5/2012

Nessus ID: 59057, 59088, 58988

Risk Information

CVSS v2

Risk Factor: High

Base Score: 8.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 5/8/2012

Vulnerability Publication Date: 5/6/2012

Exploitable With

Metasploit (PHP apache_request_headers Function Buffer Overflow)

Reference Information

CVE: CVE-2012-2336, CVE-2012-2335, CVE-2012-2311, CVE-2012-2329

BID: 53388, 53455