OpenSSL < 0.9.8m Multiple Vulnerabilities

High Log Correlation Engine Plugin ID 801064


The remote host is vulnerable to multiple attack vectors.


According to its banner, the remote host is running a version of OpenSSL older than 0.9.8m. Such versions potentially have the following vulnerabilities :

- Session renegotiations are not handled properly, which could be exploited to insert arbitrary plaintext by a man-in-the-middle. (CVE-2009-3555)

- The library does not check for a NULL return value from calls to the bn_wexpand() function, which has unspecified impact. (CVE-2009-3245)

IAVA Reference : 2011-A-0107
IAVB Reference : 2012-B-0038
STIG Finding Severity : Category I


Upgrade to OpenSSL 0.9.8m or later.

See Also;user=guest&amp;pass=guest;m=126714485629486&amp;w=2

Plugin Details

Severity: High

ID: 801064

Family: Web Servers

Published: 2010/03/09

Nessus ID: 42880, 45039

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2010/02/25

Vulnerability Publication Date: 2009/11/09

Reference Information

CVE: CVE-2009-3245, CVE-2009-3555

BID: 38562, 36935