OpenSSL < 0.9.8q / 1.0.0c Multiple Vulnerabilities

Medium Log Correlation Engine Plugin ID 801055

Synopsis

The remote web server is vulnerable to multiple attack vectors.

Description

Versions of OpenSSL earlier than 0.9.8q and 1.0.0c are potentially affected by multiple vulnerabilities :

- It may be possible to downgrade the ciphersuite to a weaker version by modifying the stored session cache cipher suite.

- An error exists in the J-PAKE implementation which could lead to successful validation by someone with no knowledge of the shared secret.
IAVA Reference : 2011-A-0160
IAVB Reference : 2012-B-0038
STIG Finding Severity : Category I

Solution

Upgrade to OpenSSL 0.9.8q, 1.0.0c, or later.

See Also

http://.openssl.org/news/secadv_20101202.txt

seb.dbzteam.org/crypto/jpake-session-key-retrieval.pdf

Plugin Details

Severity: Medium

ID: 801055

File Name: 801055.prm

Family: Web Servers

Published: 2010/12/07

Nessus ID: 51058, 51892

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.1

Temporal Score: 3.8

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2010/12/02

Vulnerability Publication Date: 2010/12/02

Reference Information

CVE: CVE-2010-4180, CVE-2010-4252

BID: 45163, 45164