OpenSSL < 0.9.8r / 1.0.0d OCSP Stapling Denial of Service

Medium Log Correlation Engine Plugin ID 801053


The remote web server is vulnerable to multiple attack vectors.


Versions of OpenSSL earlier than 0.9.8r and 1.0.0d are potentially affected by a vulnerability wherein an incorrectly formatted ClientHello handshake message could cause OpenSSL to parse past the end of the message which could cause the web server to crash. There is also the potential for information disclosure if OCSP nonce extensions are used.


Upgrade to OpenSSL 0.9.8r, 1.0.0d, or later.

See Also

Plugin Details

Severity: Medium

ID: 801053

Family: Web Servers

Published: 2011/02/09

Nessus ID: 51919

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2011/02/08

Vulnerability Publication Date: 2011/02/08

Reference Information

CVE: CVE-2011-0014

BID: 46264