OpenSSL < 0.9.8r / 1.0.0d OCSP Stapling Denial of Service

medium Log Correlation Engine Plugin ID 801053
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is vulnerable to multiple attack vectors.

Description

Versions of OpenSSL earlier than 0.9.8r and 1.0.0d are potentially affected by a vulnerability wherein an incorrectly formatted ClientHello handshake message could cause OpenSSL to parse past the end of the message which could cause the web server to crash. There is also the potential for information disclosure if OCSP nonce extensions are used.

Solution

Upgrade to OpenSSL 0.9.8r, 1.0.0d, or later.

See Also

http://.openssl.org/news/secadv_20110208.txt

cvs.openssl.org/chngview?cn=20359

Plugin Details

Severity: Medium

ID: 801053

Family: Web Servers

Published: 2/9/2011

Updated: 2/9/2011

Nessus ID: 51919

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2/8/2011

Vulnerability Publication Date: 2/8/2011

Reference Information

CVE: CVE-2011-0014

BID: 46264