OpenSSL < 0.9.8y / 1.0.1d / 1.0.0k Multiple Vulnerabilities

medium Log Correlation Engine Plugin ID 801052
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is running an OpenSSL instance that may be affected by multiple vulnerabilities.

Description

Versions of OpenSSL prior to 0.9.8y are reportedly affected by the following vulnerabilities :

- An error exists related to the handling of OCSP response verification that could allow denial of service attacks. (CVE-2013-0166)

- An error exists related to the SSL/TLS/DTLS protocols, CBC mode encryption and response time. An attacker could obtain plaintext contents of encrypted traffic via timing attacks. (CVE-2013-0169)

Solution

Upgrade to OpenSSL 0.9.8y or later.

See Also

http://www.openssl.org/news/secadv_20130204.txt

Plugin Details

Severity: Medium

ID: 801052

Family: Web Servers

Published: 6/11/2013

Updated: 6/11/2013

Nessus ID: 64532

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 6/3/2013

Vulnerability Publication Date: 6/3/2013

Reference Information

CVE: CVE-2013-0166

BID: 60268