Safari < 3.2.3 Multiple Vulnerabilities

high Log Correlation Engine Plugin ID 800998
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to multiple attack vectors

Description

The version of Safari installed on the remote Windows host is earlier than 3.2.3. Such versions are potentially affected by several issues :

- A heap buffer overflow issue in the libxml library when handling long entity names could lead to a crash or arbitrary code execution. (CVE-2008-3529)

- Multiple input validation issues exist in Safari's handling of 'feed:' URLs, which could be abused to execute arbitrary JavaScript code. (CVE-2009-0162)

- A memory corruption issue in WebKit's handling of SVGList objects could lead to arbitrary code execution. (CVE-2009-0945)

Solution

Upgrade to Safari 3.2.3 or later.

See Also

research.microsoft.com/apps/pubs/default.aspx?id=79323

support.apple.com/kb/HT3550

lists.apple.com/archives/security-announce/2009/may/msg00000.html

Plugin Details

Severity: High

ID: 800998

Family: Web Clients

Nessus ID: 38745

Risk Information

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Reference Information

CVE: CVE-2009-0945, CVE-2008-3529, CVE-2009-0162

BID: 34924, 31126, 34925