Google Chrome < 5.0.375.127 Multiple Vulnerabilities

High Log Correlation Engine Plugin ID 800956


The remote host contains a web browser that is vulnerable to multiple attack vectors.


Versions of Google Chrome earlier than 5.0.375.127 are potentially affected by multiple vulnerabilities :

A memory corruption issue with file dialog. (Bug 45400)

A memory corruption issue with SVGs. (Bug 49596)

An issue relating to a bad cast with text editing. (Bug 49268)

- A possible address bar spoofing vulnerability caused by a history bug. (Bug 49964)

- A memory corruption issue in MIME type handling. (Bugs 50515, 51835)

A crash on shutdown due to a notifications bug. (Bug 50553)

Omnibox autosuggest is enabled when a user might be typing a password. (Bug 51146)

A memory corruption issue in Ruby support. (Bug 51654)

A memory corruption issue in Geolocation support. (51670)


Upgrade to Google Chrome 5.0.375.127 or later.

See Also

Plugin Details

Severity: High

ID: 800956

Family: Web Clients

Published: 2010/08/20

Nessus ID: 48383

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2010/08/19

Vulnerability Publication Date: 2010/08/19

Reference Information

CVE: CVE-2010-3112, CVE-2010-3113, CVE-2010-3114, CVE-2010-3115, CVE-2010-3116, CVE-2010-3117, CVE-2010-3118, CVE-2010-3119, CVE-2010-3120

BID: 42571, 44199, 44200, 44201, 44203