Google Chrome < 1.0.154.53 Multiple Vulnerabilities

medium Log Correlation Engine Plugin ID 800933
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host contains a web browser that is vulnerable to multiple attack vectors.

Description

The version of Google Chrome installed on the remote host is earlier than 1.0.154.53. Such versions are reportedly affected by a multiple vulnerabilities :

- The browser uses the HTTP Host header to determine the context of a 4xx/5xx CONNECT response from a proxy server. This could allow a man-in-the-middle attacker to execute arbitrary script code in the context of a legitimate server. (CVE-2009-2060)

- The browser displays a cached certificate for 4xx/5xx CONNECT response pages from a proxy server. A man-in-the-middle attacker could exploit this by displaying a spoofed web page with the valid certificate of a legitimate website.

Solution

Upgrade to Google Chrome 1.0.154.53 or later.

See Also

sites.google.com/a/chromium.org/dev/getting-involved/dev-channel/release-notes/releasenotes1015453

Plugin Details

Severity: Medium

ID: 800933

Family: Web Clients

Nessus ID: 39499

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Reference Information

CVE: CVE-2009-1836, CVE-2009-2069, CVE-2009-2070, CVE-2009-2072, CVE-2009-2060, CVE-2009-2071

BID: 35380, 35411