Google Chrome < 24.0.1312.52 Multiple Vulnerabilities

High Log Correlation Engine Plugin ID 800917

Synopsis

The remote host contains a web browser that is affected by multiple vulnerabilities.

Description

Versions of Google Chrome earlier than 24.0.1312.52 are potentially affected by the following vulnerabilities :

- Use-after-free errors exist related to SVG layout, DOM handling, video seeking, PDF fields and printing. (CVE-2012-5145, CVE-2012-5147, CVE-2012-5150, CVE-2012-5156, CVE-2013-0832)

- An error related to malformed URLs can allow a Same Origin Policy (SOP) bypass, thereby allowing cross-site scripting attacks. (CVE-2012-5146)

- A user-input validation error exists related to filenames and hyphenation support. (CVE-2012-5148)

- Integer overflow errors exist related to audio IPC handling, PDF JavaScript and shared memory allocation. (CVE-2012-5149, CVE-2012-5151, CVE-2012-5154)

- Out-of-bounds read errors exist related to video seeking, PDF image handling, printing and glyph handling. (CVE-2012-5152, CVE-2012-5157, CVE-2012-0833, CVE-2012-0834)

- An out-of-bounds stack access error exists in the v8 JavaScript engine. (CVE-2012-5153)

- A casting error exists related to PDF 'root' handling. (CVE-2013-0828)

- An unspecified error exists that can corrupt database metadata leading to incorrect file access. (CVE-2013-0829)

- An error exists related to IPC and 'NUL' termination. (CVE-2013-0830)

- An error exists related to extensions that may allow improper path traversals. (CVE-2013-0831)

- An unspecified error exists related to geolocation. (CVE-2013-0835)

- An unspecified error exists related to garbage collection in the v8 JavaScript engine. (CVE-2013-0836)

- An unspecified error exists related to extension tab handling. (CVE-2013-0837)

- The bundled version of Adobe Flash Player contains flaws that can lead to arbitrary code execution. (CVE-2013-0630)
Successful exploitation of some of these issues could lead to an application crash or even allow arbitrary code execution, subject to the user's privileges.

Solution

Upgrade to Google Chrome 24.0.1312.52 or later.

See Also

http://www.nessus.org/u?4ab915a3

http://www.adobe.com/support/security/bulletins/apsb13-01.html

Plugin Details

Severity: High

ID: 800917

File Name: 800917.prm

Family: Web Clients

Published: 2012/01/10

Nessus ID: 63468

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2012/01/10

Vulnerability Publication Date: 2013/01/08

Reference Information

CVE: CVE-2012-5145, CVE-2012-5146, CVE-2012-5147, CVE-2012-5148, CVE-2012-5149, CVE-2012-5150, CVE-2012-5151, CVE-2012-5152, CVE-2012-5153, CVE-2012-5154, CVE-2012-5155, CVE-2012-5156, CVE-2012-5157, CVE-2013-0630, CVE-2013-0828, CVE-2013-0829, CVE-2013-0830, CVE-2013-0831, CVE-2013-0832, CVE-2013-0833, CVE-2013-0834, CVE-2013-0835, CVE-2013-0836, CVE-2013-0837, CVE-2013-0838

BID: 57184, 59413, 59414, 59415, 59416, 59417, 59418, 59419, 59420, 59421, 59422, 59423, 59424, 59425, 59426, 59427, 59428, 59429, 59430, 59431, 59433, 59435, 59436, 59437, 59438