Opera < 10.10 Multiple Vulnerabilities

high Log Correlation Engine Plugin ID 800847
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The version of Opera installed on the remote host is earlier than 10.01. Such versions are potentially affected by multiple vulnerabilities :

- Error messages can leak onto unrelated sites, potentially leading to cross-site scripting attacks. (941)

- A heap buffer overflow in string to number conversion. (942)

Solution

Upgrade to Opera 10.10 or later.

See Also

http://.opera.com/support/kb/view/941

http://.opera.com/support/kb/view/942

http://.securityfocus.com/archive/1/507980/30/0/threaded

http://.opera.com/docs/changelogs/windows/1010

Plugin Details

Severity: High

ID: 800847

Family: Web Clients

Published: 11/24/2009

Updated: 11/24/2009

Nessus ID: 42892

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 11/23/2009

Vulnerability Publication Date: 11/20/2009

Reference Information

CVE: CVE-2009-0689, CVE-2009-4072, CVE-2009-4071

BID: 37078, 37089