Apache CouchDB < 1.0.4 / 1.1.2 / 1.2.1 Multiple Vulnerabilities

medium Log Correlation Engine Plugin ID 800632
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by multiple vulnerabilities

Description

Versions of CouchDB earlier than 1.0.4, 1.1.x earlier than 1.1.2 or 1.2.x earlier than 1.2.1. It is therefore potentially affected by the following vulnerabilities :

- An unspecified error exists in the included MochiWeb HTTP library that can allow access to arbitrary files via directory traversal attacks. Note that reportedly, this issue only affects installs on Windows hosts. (CVE-2012-5641)

- An error related to JSONP callbacks can allow an unspecified cross-site scripting attack. (CVE-2012-5649)

- An input validation error exists related to unspecified query parameters and the Futon UI that can allow DOM-based cross-site scripting attacks. (CVE-2012-5650)

Solution

Upgrade to CouchDB 1.0.4 / 1.1.2 / 1.2.1 or later

See Also

http://www.securityfocus.com/archive/1/525297/30/0/threaded

http://www.securityfocus.com/archive/1/525299/30/0/threaded

http://www.securityfocus.com/archive/1/525300/30/0/threaded

Plugin Details

Severity: Medium

ID: 800632

Family: Database

Published: 5/8/2013

Updated: 5/8/2013

Nessus ID: 63642

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 1/14/2013

Vulnerability Publication Date: 1/14/2013

Reference Information

CVE: CVE-2012-5641, CVE-2012-5649, CVE-2012-5650

BID: 57313, 57314, 57321