Apache Tomcat < 5.5.29 / 6.0.24

medium Log Correlation Engine Plugin ID 800619


The remote web server is vulnerable to multiple attack vectors.


The version of Apache Tomcat installed on the remote host is earlier than 5.5.29, or 6.0.24. Such versions are potentially affected by multiple vulnerabilities :

- When deploying WAR files, the WAR files are not checked for directory traversal attempts. This allows an attacker to create arbitrary content outside of the web root by including entries such as '../../bin/catalina.sh' in the WAR. (CVE-2009-2693)

- By default, Tomcat automatically deploys any directories placed in a host's appBase. Depending on circumstances, files normally protected by one or more security constraints may be deployed without those security constraints, making them accessible without authentication. (CVE-2009-2901)

- When deploying WAR files, the WAR file names are not checked for directory traversal attempts, which could lead to the deletion of arbitrary files in the host's work directory. (CVE-2009-2902)


Upgrade to Apache Tomcat 5.5.29, 6.0.24, or later.

See Also



Plugin Details

Severity: Medium

ID: 800619

Family: Web Servers

Published: 1/25/2009

Updated: 1/25/2009

Nessus ID: 44314

Risk Information


Risk Factor: Medium

Base Score: 6.4

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 1/25/2009

Vulnerability Publication Date: 1/25/2009

Reference Information

CVE: CVE-2009-2693, CVE-2009-2902, CVE-2009-2901

BID: 37942, 37944, 37945