Apache Tomcat < 5.5.29 / 6.0.24

Medium Log Correlation Engine Plugin ID 800619

Synopsis

The remote web server is vulnerable to multiple attack vectors.

Description

The version of Apache Tomcat installed on the remote host is earlier than 5.5.29, or 6.0.24. Such versions are potentially affected by multiple vulnerabilities :

- When deploying WAR files, the WAR files are not checked for directory traversal attempts. This allows an attacker to create arbitrary content outside of the web root by including entries such as '../../bin/catalina.sh' in the WAR. (CVE-2009-2693)

- By default, Tomcat automatically deploys any directories placed in a host's appBase. Depending on circumstances, files normally protected by one or more security constraints may be deployed without those security constraints, making them accessible without authentication. (CVE-2009-2901)

- When deploying WAR files, the WAR file names are not checked for directory traversal attempts, which could lead to the deletion of arbitrary files in the host's work directory. (CVE-2009-2902)

Solution

Upgrade to Apache Tomcat 5.5.29, 6.0.24, or later.

See Also

tomcat.apache.org/security-5.html

tomcat.apache.org/security-6.html

Plugin Details

Severity: Medium

ID: 800619

File Name: 800619.prm

Family: Web Servers

Published: 2009/01/25

Nessus ID: 44314

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.4

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2009/01/25

Vulnerability Publication Date: 2009/01/25

Reference Information

CVE: CVE-2009-2693, CVE-2009-2901, CVE-2009-2902

BID: 37942, 37944, 37945