Apache Tomcat 7.0.x < 7.0.28 Header Parsing Remote Denial of Service

medium Log Correlation Engine Plugin ID 800617
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is affected by a remote denial of service vulnerabily

Description

Versions of Tomcat 7.0.x earlier than 7.0.28 are potentially affected by a remote denial of service vulnerability:

- A flaw exists within the parseHeaders() function that could allow for a crafted header to cause a remote denial of service (CVE-2012-2733)

- An error exists related to the 'NIO' connector when HTTPS and 'sendfile' are enabled that can force the application into an infinite loop. (CVE-2012-4534)

Solution

Upgrade to Apache Tomcat 7.0.28 or later.

See Also

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.28

Plugin Details

Severity: Medium

ID: 800617

Family: Web Servers

Published: 11/26/2012

Updated: 11/26/2012

Nessus ID: 62985

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 7/2/2011

Vulnerability Publication Date: 7/2/2011

Reference Information

CVE: CVE-2012-4534, CVE-2012-2733

BID: 56813, 56402