Apache Tomcat 7.0.x < 7.0.5 Cross-Site Scripting Vulnerability

Medium Log Correlation Engine Plugin ID 800614


The remote web server is affected by a cross-site scripting vulnerability.


Versions of Tomcat 7.0.x earlier than 7.0.5 are potentially affected by a cross-site scripting vulnerability because the application uses the user supplied parameters 'sort' and 'orderBy' directly wihtout filtering.


Upgrade to Apache Tomcat 7.0.5 or later.

See Also


Plugin Details

Severity: Medium

ID: 800614

Family: Web Servers

Published: 2011/02/13

Nessus ID: 51526

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2010/01/01

Vulnerability Publication Date: 2010/11/22

Reference Information

CVE: CVE-2010-4172

BID: 45015