Apache Tomcat 6.0.x < 6.0.30 Multiple Vulnerabilities

Medium Log Correlation Engine Plugin ID 800609

Synopsis

The remote web server is vulnerable to multiple attack vectors.

Description

Versions of Tomcat 6.x earlier than 6.0.30 are potentially affected by multiple vulnerabilities :

- When running under a SecurityManager it is possible for a web application to gain read/write permissions to any area on the file system. (CVE-2010-3718)

- It is possible to conduct cross-site scripting attacks via the 'sort' and 'orderBy' parameers of the Manager application. (CVE-2010-4172)

- The HTML Manager interface displays web application provided data, such as display names, without filtering. (CVE-2011-0013)

Solution

Upgrade to Apache Tomcat 6.0.30 or later.

See Also

tomcat.apache.org/security-6.html

Plugin Details

Severity: Medium

ID: 800609

File Name: 800609.prm

Family: Web Servers

Published: 2011/02/11

Nessus ID: 51526, 51975

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2011/01/13

Vulnerability Publication Date: 2010/11/22

Reference Information

CVE: CVE-2010-3718, CVE-2010-4172, CVE-2011-0013

BID: 45015, 46174, 46177