Apache Tomcat 6.0.x < 6.0.35 Multiple Vulnerabilities

High Log Correlation Engine Plugin ID 800607


The remote web server is affected by a denial of service vulnerability.


Versions of Apache Tomcat 6.0.35 are potentially affected by multiple vulnerabilities :

- Specially crafted requests are incorrectly processed by Tomcat and can cause the server to allow injection of arbitrary AJP messages. This can lead to authentication bypass and disclosure of sensitive information. Note this vulnerability only occurs when the following are true (CVE-2011-3190):

- the org.apache.jk.server.JkCoyoteHandler AJP connector is not used.
- POST requests are accepted.
- Large numbers of crafted form parameters can cause excessive CPU consumption due to hash collisions. (CVE-2011-4858, CVE-2012-0022)
IAVB Reference : 2012-B-0035
STIG Finding Severity : Category I


Upgrade to Apache Tomcat 6.0.35 or later.

See Also





Plugin Details

Severity: High

ID: 800607

File Name: 800607.prm

Family: Web Servers

Published: 2012/02/22

Nessus ID: 57080

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2011/12/05

Vulnerability Publication Date: 2011/08/20

Reference Information

CVE: CVE-2011-3190, CVE-2011-3375, CVE-2011-4858, CVE-2012-0022

BID: 49353, 51200, 51442, 51447