Apache Tomcat 5.5.x < 5.5.32 Cross-site Scripting Vulnerability

Medium Log Correlation Engine Plugin ID 800600

Synopsis

The remote web server is affected by a cross-site scripting vulnerability

Description

Versions of Tomcat 5.x earlier than 5.5.32 are potentially affected by a cross-site scripting vulnerability because the HTML Manager interface displays web application provided data, such as display names, without filtering.

Solution

Upgrade to Apache Tomcat 5.5.32 or later.

See Also

tomcat.apache.org/security-5.html

Plugin Details

Severity: Medium

ID: 800600

File Name: 800600.prm

Family: Web Servers

Published: 2011/02/11

Nessus ID: 51957

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2011/02/01

Vulnerability Publication Date: 2011/02/05

Reference Information

CVE: CVE-2011-0013

BID: 46174