Apache Tomcat < 4.1.40 / 5.5.28 / 6.0.20 Multiple Vulnerabilities

medium Log Correlation Engine Plugin ID 800598


The remote web server is affected by multiple vulnerabilities.


The version of Apache Tomcat installed on the remote host is affected by a multiple vulnerabilities :

- A username enumeration vulnerability exists when FORM based authentication with either the MemoryRealm, DataSourceRealm, or JDBCRealm is used. (CVE-2009-0580)

- A denial of service exists if Tomcat receives a request with invalid headers via the Java AJP connector. (CVE-2009-0033)

- A remote information-disclosure vulnerability exists in the 'RequestDispatcher' can be exploited to gain access to content in the 'WEB-INF' directory. (CVE-2008-5515)

- It is possible for a web application to replace the XML parser used by Tomcat to process 'web.xml', 'context.xml', and 'tld' files.


Upgrade to Apache Tomcat 4.1.40 / 5.5.28 / 6.0.20

See Also


Plugin Details

Severity: Medium

ID: 800598

Family: Web Servers

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Exploitable With

CANVAS (D2ExploitPack)

Reference Information

CVE: CVE-2009-0580, CVE-2008-5515, CVE-2009-0033, CVE-2009-0783

BID: 35193, 35196, 35263, 35416