Apache Tomcat < 4.1.40 / 5.5.28 / 6.0.20 Multiple Vulnerabilities

medium Log Correlation Engine Plugin ID 800598
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is affected by multiple vulnerabilities.

Description

The version of Apache Tomcat installed on the remote host is affected by a multiple vulnerabilities :

- A username enumeration vulnerability exists when FORM based authentication with either the MemoryRealm, DataSourceRealm, or JDBCRealm is used. (CVE-2009-0580)

- A denial of service exists if Tomcat receives a request with invalid headers via the Java AJP connector. (CVE-2009-0033)

- A remote information-disclosure vulnerability exists in the 'RequestDispatcher' can be exploited to gain access to content in the 'WEB-INF' directory. (CVE-2008-5515)

- It is possible for a web application to replace the XML parser used by Tomcat to process 'web.xml', 'context.xml', and 'tld' files.


Solution

Upgrade to Apache Tomcat 4.1.40 / 5.5.28 / 6.0.20

See Also

tomcat.apache.org/security-6.html

Plugin Details

Severity: Medium

ID: 800598

Family: Web Servers

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Exploitable With

CANVAS (D2ExploitPack)

Reference Information

CVE: CVE-2009-0580, CVE-2008-5515, CVE-2009-0033, CVE-2009-0783

BID: 35193, 35196, 35263, 35416