Apache Tomcat 7.0.x < 7.0.19 Multiple Vulnerabilities

Medium Log Correlation Engine Plugin ID 800597


The remote web server is affected by multiple vulnerabilities.


Versions of Tomcat 7.0.x earlier than 7.0.19 are potentially affected by multiple vulnerabilities :

- An issue exists in the error handling related to the MemoryUserDatabase that allows user passwords to be disclosed through log files. (CVE-2011-2204)

- An input validation issue exists that allows a local attacker to either bypass security or carry out denial of service attacks when the APR or NIO connectors are enabled. (CVE-2011-2526)


Upgrade to Apache Tomcat 7.0.19 or later.

See Also


Plugin Details

Severity: Medium

ID: 800597

Family: Web Servers

Published: 2011/08/01

Nessus ID: 55759

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2011/07/19

Vulnerability Publication Date: 2011/06/27

Reference Information

CVE: CVE-2011-2204, CVE-2011-2481, CVE-2011-2526

BID: 48667, 49147