Apache Tomcat 7.0.x < 7.0.6 Cross-Site Scripting Vulnerability

Medium Log Correlation Engine Plugin ID 800596

Synopsis

The remote web server is affected by a cross-site scripting vulnerability.

Description

Versions of Tomcat 7.0.x earlier than 7.0.6 are potentially affected by a cross-site scripting vulnerability because the HTML Manager interface display web application provided data, such as display names, without filtering.

Solution

Upgrade to Apache Tomcat 7.0.6 or later.

See Also

tomcat.apache.org/security-7.html

Plugin Details

Severity: Medium

ID: 800596

File Name: 800596.prm

Family: Web Servers

Published: 2011/02/13

Nessus ID: 51976

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2011/01/14

Vulnerability Publication Date: 2011/02/05

Reference Information

CVE: CVE-2011-0013

BID: 46174