Apache Tomcat 6.0.x < 6.0.28 Multiple Vulnerabilities

medium Log Correlation Engine Plugin ID 800595
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is vulnerable to multiple attack vectors.

Description

Versions of Tomcat 6.x earlier than 6.0.28 are potentially affected by multiple vulnerabilities :

- The 'WWW-Authenticate' HTTP header for BASIC and DIGEST authentication could potentially expose the local host name or IP adddress of the machine running Tomcat. (CVE-2010-1157)

- Several flaws in handling of the 'Transfer-Encoding' header exist that could prevent the recycling of a buffer. (CVE-2010-2227)

Solution

Upgrade to Apache Tomcat 6.0.28 or later.

See Also

tomcat.apache.org/security-6.html

Plugin Details

Severity: Medium

ID: 800595

Family: Web Servers

Published: 2/11/2011

Updated: 2/11/2011

Nessus ID: 48255

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 7/9/2010

Vulnerability Publication Date: 4/21/2010

Reference Information

CVE: CVE-2010-2227, CVE-2010-1157

BID: 41544, 39635