Apache 2.2 < 2.2.20 Multiple Vulnerabilities

High Log Correlation Engine Plugin ID 800584

Synopsis

The remote web server is vulnerable to a denial of service attack.

Description

Versions of Apache 2.2 earlier than 2.2.20 are potentially affected by a denial of service vulnerability. Making a series of HTTP requests with overlapping ranges in the Range or Request-Range request headers can result in memory and CPU exhaustion. A remote, unauthenticated attacker could exploit this flaw to make the system unresponsive.

Solution

Upgrade to Apache version 2.2.20 or later or use one of the workarounds in Apache's advisories for CVE-2011-3192.

See Also

http://archives.neohapsis.com/archives/fulldisclosure/2011-08/0203.html

http://www.gossamer-threads.com/lists/apache/dev/401638

http://www.nessus.org/u?8c61b13d

http://www.nessus.org/u?404627ec

http://www.apache.org/dist/httpd/CHANGES_2.2.20

Plugin Details

Severity: High

ID: 800584

File Name: 800584.prm

Family: Web Servers

Published: 2011/08/25

Nessus ID: 55976

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.8

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2011/08/25

Vulnerability Publication Date: 2011/08/19

Reference Information

CVE: CVE-2011-3192

BID: 49303