Apache 2.2 < 2.2.20 Multiple Vulnerabilities

high Log Correlation Engine Plugin ID 800584
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote web server is vulnerable to a denial of service attack.


Versions of Apache 2.2 earlier than 2.2.20 are potentially affected by a denial of service vulnerability. Making a series of HTTP requests with overlapping ranges in the Range or Request-Range request headers can result in memory and CPU exhaustion. A remote, unauthenticated attacker could exploit this flaw to make the system unresponsive.


Upgrade to Apache version 2.2.20 or later or use one of the workarounds in Apache's advisories for CVE-2011-3192.

See Also






Plugin Details

Severity: High

ID: 800584

Family: Web Servers

Published: 8/25/2011

Updated: 8/25/2011

Nessus ID: 55976

Risk Information


Risk Factor: High

Base Score: 7.8

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 8/25/2011

Vulnerability Publication Date: 8/19/2011

Reference Information

CVE: CVE-2011-3192

BID: 49303