Apache < 2.0.48 Multiple Vulnerabilities

high Log Correlation Engine Plugin ID 800583
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to a Denial of Service (DoS) attack.

Description

The remote host appears to be running a version of Apache 2.x that is older than 2.0.48. This version is vulnerable to a bug that may allow a rogue CGI to disable the httpd service by issuing over 4K of data to stderr. To exploit this flaw, an attacker would need the ability to upload a rogue CGI script to this server and to have it executed by the Apache daemon (httpd).

Solution

Upgrade to version 2.0.48 or higher.

See Also

http://www.securityfocus.com/bid/8926

Plugin Details

Severity: High

ID: 800583

Family: Web Servers

Risk Information

CVSS v2

Risk Factor: High

Base Score: 7.2

Temporal Score: 6.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Reference Information

CVE: CVE-2003-0542, CVE-2003-0789, CVE-2002-0061, CVE-2004-0087, CVE-2004-0090, CVE-2004-0092, CVE-2004-0085, CVE-2004-0086, CVE-2004-0088

BID: 4335, 8911, 9504, 8926