Apache HTTP Request Parsing HTML Injection

High Log Correlation Engine Plugin ID 800576


The remote host is vulnerable to a flaw in the way that it parses HTTP requests.


The remote host appears to be running a version of Apache, an open source web server. This version of Apache is vulnerable to a flaw in the way that it handles malformed HTTP requests. An attacker exploiting this flaw would be able to possibly corrupt cache memory or inject HTML requests to a vulnerable Apache server. The vulnerability stems from a non-conformance to RFC 2616 that states that HTTP requests must not include both a 'Content-Length' and 'Transfer-Encoding' field.


Upgrade to version 2.0.54, 1.3.33 or higher.

See Also


Plugin Details

Severity: High

ID: 800576

Family: Web Servers

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 8.5

Temporal Score: 7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:C/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Reference Information

CVE: CVE-2005-2088, CVE-2005-2090, CVE-2005-1993, CVE-2005-2491, CVE-2005-2757, CVE-2005-2969, CVE-2005-3185, CVE-2005-3700, CVE-2005-3701, CVE-2005-3702, CVE-2005-3704, CVE-2005-3705

BID: 15647, 14106, 13873