Apache < 2.2.14 Multiple Vulnerabilities

high Log Correlation Engine Plugin ID 800574


The remote web server is vulnerable to multiple attack vectors.


According to its banner, the version of Apache 2.2 installed on the remote host is older than 2.2.14. Such versions are potentially affected by multiple vulnerabilities :

- Faulty error handling in the Solaris pollset support (Event Port backend) which could trigger hangs in the prefork and event MPMs on that platform (CVE-2009-2699)

- The 'ap_proxy_ftp_handler' function in 'modules/proxy/proxy_ftp.c in the 'mod_proxy_ftp' module allows remote FTP servers to cause a denial-of-service via a malformed reply to an EPSV command. (CVE-2009-3094)

- The 'mod_proxy_ftp' module allows remote attackers to bypass intended access restrictions and send arbitrary commands to an FTP server. (CVE-2009-3095)


Either ensure the affected module is not in use or upgrade to Apache version 2.2.14 or later.

See Also


Plugin Details

Severity: High

ID: 800574

Family: Web Servers

Published: 10/6/2009

Updated: 10/6/2009

Nessus ID: 42052

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 5.1

Temporal Score: 4.2

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 10/5/2009

Vulnerability Publication Date: 10/5/2009

Reference Information

CVE: CVE-2009-2699, CVE-2009-3094, CVE-2009-3095

BID: 36596, 36254, 36260