Apache 2.2 < 2.2.16 Multiple Vulnerabilities

high Log Correlation Engine Plugin ID 800573
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is vulnerable to multiple attack vectors.

Description

Versions of Apache 2.2 earlier than 2.2.16 are potentially affected by multiple vulnerabilities :

- A denial-of-service vulnerability in mod_cache and mod_dav. (CVE-2010-1452)

- An information disclosure vulnerability in mod_proxy_http relating to timeout conditions. (CVE-2010-2068)

Solution

Either ensure the affected module is not in use or upgrade to Apache version 2.2.16 or later.

See Also

https://issues.apache.org/bugzilla/show_bug.cgi?id=49246

https://issues.apache.org/bugzilla/show_bug.cgi?id=49417

httpd.apache.org/security/vulnerabilities_22.html

http://www.apache.org/dist/httpd/CHANGES_2.2.16

Plugin Details

Severity: High

ID: 800573

Family: Web Servers

Published: 7/27/2010

Updated: 7/27/2010

Nessus ID: 48205

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 7/25/2010

Vulnerability Publication Date: 6/11/2010

Reference Information

CVE: CVE-2010-1452, CVE-2010-2068

BID: 41963, 40827