Apache < 2.2.12 Multiple Vulnerabilities

medium Log Correlation Engine Plugin ID 800567


The remote web server may be affected by several issues.


According to its banner, the version of Apache 2.2 installed on the remote host is older than 2.2.12. Such versions may be affected by several issues :

- A denial-of-service vulnerability in the 'mod_proxy' module could be exploited to cause the process to consume large amounts of CPU resources. (CVE-2009-1890)

- The 'mod_deflate' module is prone to a remote denial-of-service vulnerability when large file downloads are terminated before completing. (CVE-2009-1891)


Either ensure that the affected modules are not in use or upgrade to Apache version 2.2.12 or later.

See Also


Plugin Details

Severity: Medium

ID: 800567

Family: Web Servers

Published: 8/3/2009

Updated: 8/3/2009

Nessus ID: 40467

Risk Information


Risk Factor: Medium

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 7/23/2009

Vulnerability Publication Date: 7/3/2009

Reference Information

CVE: CVE-2009-1195, CVE-2009-0023, CVE-2009-1955, CVE-2009-1956, CVE-2009-1890, CVE-2009-1891, CVE-2009-1191

BID: 35221, 35251, 35253, 35565, 35623, 34663, 35115