Apache 2.2 < 2.2.21 mod_proxy_ajp DoS

high Log Correlation Engine Plugin ID 800559


The remote web server is vulnerable to a denial of service attack.


Versions of Apache 2.2 earlier than 2.2.21 are potentially affected by a denial of service vulnerability. An error exists in the mod_proxy_ajp module that can allow specially crafted HTTP requests to cause a backend server to temporarily enter an error state. This vulnerability only occurs when mod_proxy_ajp is used along with mod_proxy_balancer.


Upgrade to Apache version 2.2.21 or later.

See Also



Plugin Details

Severity: High

ID: 800559

Family: Web Servers

Published: 11/3/2011

Updated: 11/3/2011

Nessus ID: 56216

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 9/14/2011

Vulnerability Publication Date: 9/14/2011

Reference Information

CVE: CVE-2011-3348

BID: 49616