Apache HTTP Server < 2.0.49 mod_ssl Plain HTTP Request DoS

Medium Log Correlation Engine Plugin ID 800551


The remote host is vulnerable to a Denial of Service (DoS) attack


The remote host appears to be running a version of Apache 2.x which is older than 2.0.49. There is a bug in the mod_ssl module that ships with Apache 2.0.35 to 2.0.48 that makes it vulnerable to a remote denial of service. An attacker may exploit this flaw by issuing malformed SSL commands when connecting to the remote host, and may therefore use it to prevent HTTPS from working.


Upgrade to Apache/2.0.49 or later.

Plugin Details

Severity: Medium

ID: 800551

File Name: 800551.prm

Family: Web Servers

Nessus ID: 12100

Risk Information

Risk Factor: Medium


Base Score: 8.8

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Reference Information

CVE: CVE-2004-0113

BID: 9826