Apache 2.2 < 2.2.24 Multiple Cross-Site Scripting Vulnerabilities

Medium Log Correlation Engine Plugin ID 800118

Synopsis

The remote web server is affected by multiple vulnerabilities

Description

The remote host is running a Apache HTTP server. Versions earlier than 2.4.4 are vulnerable to the following vulnerabilities :

- Errors exist related to the modules mod_info, mod_status, mod_imagemap, mod_ldap, and mod_proxy_ftp and unescaped hostnames and URIs that could allow cross-site scripting attacks. (CVE-2012-3499)

- An error exists related to the mod_proxy_balancer module's manager interface that could allow cross-site scripting attacks. (CVE-2012-4558)

Solution

Either ensure that the affected modules are not in use or upgrade to Apache version 2.2.24 or later

See Also

http://www.apache.org/dist/httpd/CHANGES_2.2.24

http://httpd.apache.org/security/vulnerabilities_22.html

Plugin Details

Severity: Medium

ID: 800118

File Name: 800118.prm

Family: Web Servers

Published: 2013/02/27

Nessus ID: 64912

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2013/02/25

Vulnerability Publication Date: 2013/02/18

Reference Information

CVE: CVE-2012-3499, CVE-2012-4558

BID: 58165