FreeBSD : codeigniter -- multiple vulnerabilities (71ebbc50-01c1-11e7-ae1b-002590263bf5)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing a security-related update.

Description :

The CodeIgniter changelog reports :

Fixed an XSS vulnerability in Security Library method xss_clean().

Fixed a possible file inclusion vulnerability in Loader Library method
vars().

Fixed a possible remote code execution vulnerability in the Email
Library when 'mail' or 'sendmail' are used (thanks to Paul
Buonopane from NamePros).

Added protection against timing side-channel attacks in Security
Library method csrf_verify().

Added protection against BREACH attacks targeting the CSRF token field
generated by Form Helper function form_open().

See also :

https://www.codeigniter.com/user_guide/changelog.html
http://www.nessus.org/u?6f559812

Solution :

Update the affected package.

Risk factor :

High

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 97545 ()

Bugtraq ID:

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now