openSUSE Security Update : perl-DBD-mysql (openSUSE-2017-130)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for perl-DBD-mysql fixes the following issues :

- CVE-2016-1251: A use-after-free when used with
mysql_server_prepare=1 (bsc#1012546).

- CVE-2016-1246: Buffer overflow allowed context-dependent
attackers to cause a denial of service (crash) via
vectors related to an error message (bsc#1002626).

- CVE-2016-1249: Out-of-bounds read when using server-side
prepared statement support (bsc#1010457).

This update was imported from the SUSE:SLE-12:Update update project.

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1002626
https://bugzilla.opensuse.org/show_bug.cgi?id=1010457
https://bugzilla.opensuse.org/show_bug.cgi?id=1012546

Solution :

Update the affected perl-DBD-mysql packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 96711 ()

Bugtraq ID:

CVE ID: CVE-2016-1246
CVE-2016-1249
CVE-2016-1251

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now