Apache Struts 2.5.x < 2.5.8 URLValidator Form Field Handling Remote DoS

This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a web application that uses a Java
framework that is affected by a denial of service vulnerability.

Description :

The version of Apache Struts running on the remote Windows host is
2.5.x prior to 2.5.8. It is, therefore, potentially affected by a
denial of service vulnerability in the URLValidator class due to
improper handling of user-supplied input to the form field. An
unauthenticated, remote attacker can exploit this, via a specially
crafted URL, to overload server processes.

Note that Nessus has not tested for this issue but has instead relied
only on the application's self-reported version number.

See also :

https://cwiki.apache.org/confluence/display/WW/Version+Notes+2.5.8
https://cwiki.apache.org/confluence/display/WW/S2-044

Solution :

Upgrade to Apache Struts version 2.5.8 or later. Alternatively,
apply the workaround referenced in the vendor advisory.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.1
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 95887 ()

Bugtraq ID: 94657

CVE ID: CVE-2016-8738

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now