Apache Struts 2.3.2x / 2.3.3x < 2.3.31 Convention Plugin Path Traversal RCE

This script is Copyright (C) 2016 Tenable Network Security, Inc.

Synopsis :

The remote Windows host contains a web application that uses a Java
framework that is affected by a remote code execution vulnerability.

Description :

The version of Apache Struts running on the remote Windows host is
2.3.2x or 2.3.3x prior to 2.3.30. It is, therefore, affected by a
remote code execution vulnerability in the Convention plugin due to a
flaw that allows traversing outside of a restricted path. An
unauthenticated, remote attacker can exploit this, via a crafted path
traversal request, to execute arbitrary code on the remote server.

Note that Nessus has not tested for this issue but has instead
relied only on the application's self-reported version number.

See also :


Solution :

Upgrade to Apache Struts version 2.3.31 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
CVSS Temporal Score : 7.4
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 94336 ()

Bugtraq ID: 93773

CVE ID: CVE-2016-6795

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now