openSUSE Security Update : flash-player (openSUSE-2016-1183)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for flash-player fixes the following security issues :

- CVE-2016-4273: Unspecified memory corruption
vulnerability that could lead to code execution

- CVE-2016-4286: Unspecified security bypass vulnerability

- CVE-2016-6981: Unspecified use-after-free vulnerability
that could lead to code execution

- CVE-2016-6982: Unspecified memory corruption
vulnerability that could lead to code execution

- CVE-2016-6983: Unspecified memory corruption
vulnerability that could lead to code execution

- CVE-2016-6984: Unspecified memory corruption
vulnerability that could lead to code execution

- CVE-2016-6985: Unspecified memory corruption
vulnerability that could lead to code execution

- CVE-2016-6986: Unspecified memory corruption
vulnerability that could lead to code execution

- CVE-2016-6987: Unspecified use-after-free vulnerability
that could lead to code execution

- CVE-2016-6989: Unspecified memory corruption
vulnerability that could lead to code execution

- CVE-2016-6990: Unspecified memory corruption
vulnerability that could lead to code execution

- CVE-2016-6992: Unspecified type confusion vulnerability
that could lead to code execution

The EULA was updated to version 23.0 (boo#1003993).

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1003993
https://bugzilla.opensuse.org/show_bug.cgi?id=1004019

Solution :

Update the affected flash-player packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now