VMware Tools 9.x / 10.x < 10.0.9 Multiple Privilege Escalations (VMSA-2016-0014) (Mac OS X)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

A virtualization application installed on the remote Mac OS X host is
affected by multiple privilege escalation vulnerabilities.

Description :

The version of VMware Tools installed on the remote Mac OS X host is
9.x or 10.x prior to 10.0.9. It is, therefore, affected by multiple
NULL pointer dereference flaws in the graphic acceleration functions
due to improper memory handling. A local attacker can exploit these to
gain elevated privileges.

See also :

http://www.vmware.com/security/advisories/VMSA-2016-0014.html

Solution :

Upgrade to VMware Tools version 10.0.9 or later.

Risk factor :

High / CVSS Base Score : 7.2
(CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 5.3
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 93520 ()

Bugtraq ID: 92938

CVE ID: CVE-2016-7079
CVE-2016-7080

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now