Samba 4.x < 4.2.14 / 4.3.x < 4.3.11 / 4.4.x < 4.4.5 SMB2/3 Client Connection Required Signing Downgrade

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote Samba server is affected by a signature downgrade
vulnerability.

Description :

The version of Samba running on the remote host is 4.x prior to
4.2.14, 4.3.x prior to 4.3.11, or 4.4.x prior to 4.4.5. It is,
therefore, affected by a flaw in libcli/smb/smbXcli_base.c that is
triggered when handling SMB2 and SMB3 client connections. A
man-in-the-middle attacker can exploit this, by injecting the
SMB2_SESSION_FLAG_IS_GUEST or SMB2_SESSION_FLAG_IS_NULL flags, to
downgrade the required signing for a client connection, allowing the
attacker to spoof SMB2 and SMB3 servers.

See also :

https://www.samba.org/samba/security/CVE-2016-2119.html
http://www.samba.org/samba/history/samba-4.2.14.html
http://www.samba.org/samba/history/samba-4.3.11.html
http://www.samba.org/samba/history/samba-4.4.5.html

Solution :

Upgrade to Samba version 4.2.14 / 4.3.11 / 4.4.5 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.0
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 92466 ()

Bugtraq ID: 91700

CVE ID: CVE-2016-2119

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now