openSUSE Security Update : vlc (openSUSE-2016-755)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for vlc to version 2.1.6 fixes the following issues :

These CVE were fixed :

- CVE-2016-5108: Reject invalid QuickTime IMA files
(boo#984382).

- CVE-2016-3941: Heap overflow in processing wav files
(boo#973354).

These security issues without were fixed :

- Fix heap overflow in decomp stream filter.

- Fix buffer overflow in updater.

- Fix potential buffer overflow in schroedinger encoder.

- Fix NULL pointer dereference in DMO decoder.

- Fix buffer overflow in parsing of string boxes in mp4
demuxer.

- Fix SRTP integer overflow.

- Fix potential crash in zip access.

- Fix read overflow in Ogg demuxer.

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=973354
https://bugzilla.opensuse.org/show_bug.cgi?id=984382

Solution :

Update the affected vlc packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 91773 ()

Bugtraq ID:

CVE ID: CVE-2016-3941
CVE-2016-5108

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now