OpenSSH < 7.2p2 X11Forwarding xauth Command Injection

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The SSH server running on the remote host is affected by a security
bypass vulnerability.

Description :

According to its banner, the version of OpenSSH running on the remote
host is prior to 7.2p2. It is, therefore, affected by a security
bypass vulnerability due to improper sanitization of X11
authentication credentials. An authenticated, remote attacker can
exploit this, via crafted credentials, to inject arbitrary xauth
commands, resulting in gaining read and write access to arbitrary
files, connecting to local ports, or performing further attacks on
xauth itself. Note that exploiting this vulnerability requires
X11Forwarding to have been enabled.

See also :

http://www.openssh.com/txt/release-7.2p2
http://www.openssh.com/txt/x11fwd.adv

Solution :

Upgrade to OpenSSH version 7.2p2 or later.

Risk factor :

Medium / CVSS Base Score : 4.9
(CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:N)
CVSS Temporal Score : 4.0
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 90023 ()

Bugtraq ID:

CVE ID: CVE-2016-3115

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now