openSUSE Security Update : python-Pillow (openSUSE-2016-339)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for python-Pillow fixes the following issues :

- backport security fixes from 3.1.1
(Pillow-overflows.patch) :

- Fixed an integer overflow in Resample.c causing writes
in the Python heap.

- Fixed a buffer overflow in PcdDecode.c causing a
segfault when opening PhotoCD files. CVE-2016-TBD

- Fixed a buffer overflow in FliDecode.c causing a
segfault when opening FLI files. CVE-2016-0775 (fixes
boo#965582)

- Fixed a buffer overflow in TiffDecode.c causing an
arbitrary amount of memory to be overwritten when
opening a specially crafted invalid TIFF file.
CVE-2016-0740 (fixes boo#965579)

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=965579
https://bugzilla.opensuse.org/show_bug.cgi?id=965582

Solution :

Update the affected python-Pillow packages.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)

Family: SuSE Local Security Checks

Nessus Plugin ID: 89949 ()

Bugtraq ID:

CVE ID: CVE-2016-0740
CVE-2016-0775

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now