FreeBSD : brotli -- buffer overflow (1bcfd963-e483-41b8-ab8e-bad5c3ce49c9)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing one or more security-related
updates.

Description :

Google Chrome Releases reports :

[583607] High CVE-2016-1624: Buffer overflow in Brotli. Credit to
lukezli.

Mozilla Foundation reports :

Security researcher Luke Li reported a pointer underflow bug in the
Brotli library's decompression that leads to a buffer overflow. This
results in a potentially exploitable crash when triggered.

See also :

http://www.nessus.org/u?f9d76078
http://www.nessus.org/u?609f6b88
https://www.mozilla.org/security/advisories/mfsa2016-30/
https://hg.mozilla.org/releases/mozilla-release/rev/4a5d8ade4e3e
http://www.nessus.org/u?46877204

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 89764 ()

Bugtraq ID:

CVE ID: CVE-2016-1624
CVE-2016-1968

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now