FreeBSD : py-rsa -- Bleichenbacher'06 signature forgery vulnerability (e78bfc9d-cb1e-11e5-b251-0050562a4d7b)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing one or more security-related
updates.

Description :

Filippo Valsorda reports :

python-rsa is vulnerable to a straightforward variant of the
Bleichenbacher'06 attack against RSA signature verification with low
public exponent.

See also :

http://www.nessus.org/u?24eb0dd8
http://www.nessus.org/u?525636eb
https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-1494
http://www.openwall.com/lists/oss-security/2016/01/05/3
http://www.openwall.com/lists/oss-security/2016/01/05/1
http://www.nessus.org/u?f242d522

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N)

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 88585 ()

Bugtraq ID:

CVE ID: CVE-2016-1494

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now