OpenSSL 1.0.2 < 1.0.2f Multiple Vulnerabilities (Logjam)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote service is affected by multiple vulnerabilities.

Description :

According to its banner, the remote host is running a version of
OpenSSL 1.0.2 prior to 1.0.2f. It is, therefore, affected by the
following vulnerabilities :

- A cipher algorithm downgrade vulnerability exists due to
a flaw that is triggered when handling cipher
negotiation. A remote attacker can exploit this to
negotiate SSLv2 ciphers and complete SSLv2 handshakes
even if all SSLv2 ciphers have been disabled on the
server. Note that this vulnerability only exists if the
SSL_OP_NO_SSLv2 option has not been disabled.
(CVE-2015-3197)

- A man-in-the-middle vulnerability, known as Logjam,
exists due to a flaw in the SSL/TLS protocol. A remote
attacker can exploit this flaw to downgrade connections
using ephemeral Diffie-Hellman key exchange to 512-bit
export-grade cryptography. (CVE-2015-4000)

- An information disclosure vulnerability exists due to a
flaw in the DH_check_pub_key() function that is
triggered when generating DH parameters based on unsafe
primes. A remote attacker can exploit this, via multiple
handshakes, to disclose the private DH exponent.
(CVE-2016-0701)

See also :

https://www.openssl.org/news/secadv/20160128.txt
https://weakdh.org/

Solution :

Upgrade to OpenSSL version 1.0.2f or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:F/RL:TF/RC:ND)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 88530 ()

Bugtraq ID: 74733

CVE ID: CVE-2015-3197
CVE-2015-4000
CVE-2016-0701

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now