openSUSE Security Update : nodejs (openSUSE-2016-46)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update contains nodejs 4.2.4 and fixes the following issues :

- CVE-2015-6764: unspecified out-of-bounds access
vulnerability (boo#956902)

- CVE-2015-8027: unspecified denial of service
vulnerability (boo#956901)

The following non-security bugs were fixed :

- boo#948045: Nodejs 4.0 rpm does not install
addon-rpm.gypi

- boo#961254: common.gypi should install at
/usr/share/node and npm requires nodejs-devel

Also contains all upstream bug fixes and improvements in the 4.2.2,
4.2.3 and 4.2.4 releases.

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=948045
https://bugzilla.opensuse.org/show_bug.cgi?id=956901
https://bugzilla.opensuse.org/show_bug.cgi?id=956902
https://bugzilla.opensuse.org/show_bug.cgi?id=961254

Solution :

Update the affected nodejs packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 88130 ()

Bugtraq ID:

CVE ID: CVE-2015-6764
CVE-2015-8027

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now