openSUSE Security Update : php5 (openSUSE-2015-536)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

PHP was updated to fix two security issues.

The following vulnerabilities were fixed :

- CVE-2015-5589: PHP could be crashed when processing an
invalid file with the 'phar' extension with a segfault
in Phar::convertToData, leading to Denial of Service
(DOS) (boo#938721)

- CVE-2015-5590: PHP could be crashed or have unspecified
other impact due to a buffer overlow in
phar_fix_filepath (boo#938719)

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=938719
https://bugzilla.opensuse.org/show_bug.cgi?id=938721

Solution :

Update the affected php5 packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: SuSE Local Security Checks

Nessus Plugin ID: 85259 ()

Bugtraq ID:

CVE ID: CVE-2015-5589
CVE-2015-5590

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now