VMware Workstation 10.x < 10.0.7 / 11.x < 11.1.1 DACL Privilege Escalation (VMSA-2015-0005)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The virtualization application installed on the remote host is
affected by a privilege escalation vulnerability.

Description :

The version of VMware Workstation installed on the remote host is 10.x
prior to 10.0.7 or 11.x prior to 11.1.1. It is, therefore, affected by
a privilege escalation vulnerability due to a failure to provide a
valid discretionary access control list (DACL) pointer for the
printproxy.exe process. A local attacker, using thread injection, can
exploit this to gain elevated privileges or execute arbitrary code.

See also :

http://www.vmware.com/security/advisories/VMSA-2015-0005.html

Solution :

Upgrade to VMware Workstation version 10.0.7 / 11.1.1 or later.

Risk factor :

High / CVSS Base Score : 7.2
(CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 5.3
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 84806 ()

Bugtraq ID: 75686

CVE ID: CVE-2015-3650

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now