GLSA-201502-04 : MediaWiki: Multiple vulnerabilities

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201502-04
(MediaWiki: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in MediaWiki. Please
review the CVE identifiers and MediaWiki announcement referenced below
for details.

Impact :

A remote attacker may be able to execute arbitrary code with the
privileges of the process, create a Denial of Service condition, obtain
sensitive information, bypass security restrictions, and inject arbitrary
web script or HTML.

Workaround :

There is no known workaround at this time.

See also :

http://www.nessus.org/u?4ef35312
https://security.gentoo.org/glsa/201502-04

Solution :

All MediaWiki 1.23 users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=www-apps/mediawiki-1.23.8'
All MediaWiki 1.22 users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=www-apps/mediawiki-1.22.15'
All MediaWiki 1.19 users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=www-apps/mediawiki-1.19.23'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
Public Exploit Available : true