FreeBSD : openldap -- two remote denial of service vulnerabilities (a0c45e53-ae51-11e4-8ac7-d050992ecde8)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing a security-related update.

Description :

Ryan Tandy reports :

With the deref overlay enabled, ldapsearch with '-E deref=member:'
causes slapd to crash.

Bill MacAllister discovered that certain queries cause slapd to crash
while freeing operation controls. This is a 2.4.40 regression. Earlier
releases are not affected.

See also :

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=776988
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=776991
http://www.nessus.org/u?f4a5dcaf

Solution :

Update the affected package.

Risk factor :

High

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 81222 ()

Bugtraq ID:

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now