ESXi 5.5 < Build 2352327 Multiple Vulnerabilities (remote check) (POODLE)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote VMware ESXi 5.5 host is affected by multiple
vulnerabilities.

Description :

The remote VMware ESXi host is version 5.5 prior to build 2352327. It
is, therefore, affected by the following vulnerabilities :

- An error exists related to DTLS SRTP extension handling
and specially crafted handshake messages that can allow
denial of service attacks via memory leaks.
(CVE-2014-3513)

- An error exists related to the way SSL 3.0 handles
padding bytes when decrypting messages encrypted using
block ciphers in cipher block chaining (CBC) mode. A
man-in-the-middle attacker can decrypt a selected byte
of a cipher text in as few as 256 tries if they are able
to force a victim application to repeatedly send the
same data over newly created SSL 3.0 connections. This
is also known as the 'POODLE' issue. (CVE-2014-3566)

- An error exists related to session ticket handling that
can allow denial of service attacks via memory leaks.
(CVE-2014-3567)

- An error exists related to the build configuration
process and the 'no-ssl3' build option that allows
servers and clients to process insecure SSL 3.0
handshake messages. (CVE-2014-3568)

- A denial of service vulnerability in libxml2 due to
entity expansion even when entity substitution is
disabled. A remote attacker, using a crafted XML
document containing larger number of nested entity
references, can cause the consumption of CPU resources.
(CVE-2014-3660)

- An unspecified privilege escalation vulnerability.
(CVE-2014-8370)

- An unspecified denial of service vulnerability due to an
input validation issue in the VMware Authorization
process (vmware-authd). (CVE-2015-1044)

See also :

https://www.vmware.com/security/advisories/VMSA-2015-0001.html
https://www.imperialviolet.org/2014/10/14/poodle.html
https://www.openssl.org/~bodo/ssl-poodle.pdf
https://tools.ietf.org/html/draft-ietf-tls-downgrade-scsv-00

Solution :

Apply patch ESXi550-201403102-SG and ESXi550-201501101-SG for ESXi
5.5.

Risk factor :

High / CVSS Base Score : 7.1
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C)
CVSS Temporal Score : 6.2
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now